use strict;
my $str = '* Remove punctuation then spaces *
';
my $regex = qr/^x-y/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";