package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{7,7})*`)
var str = `a75z6878`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}