#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=.*video\.cnbc\.com)"
Local $sString = "video.cnbc.com/id/33333" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"cnbc.com/id/34243424234" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"video.cnbc.com/id/wer423424"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")