$re = '/(?=.*video\.cnbc\.com)/';
$str = 'video.cnbc.com/id/33333
cnbc.com/id/34243424234
video.cnbc.com/id/wer423424';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);