re = /(?=.*video\.cnbc\.com)/
str = 'video.cnbc.com/id/33333
cnbc.com/id/34243424234
video.cnbc.com/id/wer423424'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end