use strict;
my $str = '\'la \'Mule';
my $regex = qr/^[a-z0-9]+([a-z0-9 '&,-]*)+/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";