Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
\([^\)]*\)*
"
g
Input 1
1
New
hello(there) how(are(you(today))) my(lad) I'm (fine) (thanks)