Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(str)(?=(?:[^'"]|["'][^'"]*["'])*$)
/
g
Test String
New
test str , a "comma, si str", bobsi str "si,sam, str",here si str ' hh str si'
Substitution
Processing...
newstr