# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(str)(?=(?:[^'\"]|[\"'][^'\"]*[\"'])*$)"
test_str = "test str , a \"comma, si str\", bobsi str \"si,sam, str\",here si str ' hh str si'"
subst = "newstr"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.