re = /(str)(?=(?:[^'"]|["'][^'"]*["'])*$)/
str = 'test str , a "comma, si str", bobsi str "si,sam, str",here si str \' hh str si\''
subst = 'newstr'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result