use strict;
my $str = '<div class="Select is-searchable" data-reactid=".0.2.0.0.$1.0.0.0.1.0.0"><input type="hidden" value="" data-reactid=".0.2.0.0.$1.0.0.0.1.0.0.0"><div class="Select-control" data-reactid=".0.2.0.0.$1.0.0.0.1.0.0.1"><div class="Select-placeholder" data-reactid=".0.2.0.0.$1.0.0.0.1.0.0.1.0:$placeholder">Select...</div><div class="Select-input" style="display:inline-block;" data-reactid=".0.2.0.0.$1.0.0.0.1.0.0.1.1"><input value="" tabindex="0" style="width:5px;" data-reactid=".0.2.0.0.$1.0.0.0.1.0.0.1.1.0"><div style="position: absolute; visibility: hidden; height: 0px; width: 0px; overflow: scroll; white-space: nowrap; font-size: 16.2000007629395px; font-family: montserrat, sans-serif;" data-reactid=".0.2.0.0.$1.0.0.0.1.0.0.1.1.1"></div></div><span class="Select-arrow" data-reactid=".0.2.0.0.$1.0.0.0.1.0.0.1.2"></span></div></div>';
my $regex = qr/data-reactid="([0-9a-zA-Z\.\$\:]*)"/p;
if ( $str =~ /$regex/g ) {
  print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
  # print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
  # print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}