const regex = /src="([^'"]+)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('src="([^\'"]+)"', 'g')
const str = `<img src="images/logo.png" />
<img src="{% static 'img/logo.png' %}" />`;
const subst = `src="{% static '\1' %}"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);