using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[@|#](.*?)\s";
string input = @"Hi this is a test @info@test.com and @martin we have to go.
@info@test.com , do not enter.
Look at #ean-4456 is not valid, please verify #ean-2245 to do this.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}