#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)nan|(?:2019|202[0-5])"
Local $sString = "21 JUNE 23.59" & @CRLF & _
"18TH JUN 23:59" & @CRLF & _
"01TH JULY (23.59 HRS)" & @CRLF & _
"28th June 2023" & @CRLF & _
"5TH MAY 2023" & @CRLF & _
"JUNE 27, 2023"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")