using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"nan|(?:2019|202[0-5])";
string input = @"21 JUNE 23.59
18TH JUN 23:59
01TH JULY (23.59 HRS)
28th June 2023
5TH MAY 2023
JUNE 27, 2023";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}