package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)nan|(?:2019|202[0-5])`)
var str = `21 JUNE 23.59
18TH JUN 23:59
01TH JULY (23.59 HRS)
28th June 2023
5TH MAY 2023
JUNE 27, 2023`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}