use strict;
my $str = '12345-1234
12345
1
12
123
1234
12345-
12345-1
12345-12
12345-123
';
my $regex = qr/(^[0-9]{4}?[0-9]$|^[0-9]{4}?[0-9]-[0-9]{4}$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";