import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[A-Za-z].*[A-Za-z])([A-Za-z0-9]((?!.*[\\._]{2})([\\w\\d\\.]{1,23}))[A-Za-z0-9])$";
final String string = "A.s\n"
+ "0as\n"
+ "a.a\n"
+ "a.0\n"
+ "0.0\n"
+ "a._a\n"
+ "a.0a\n"
+ "1rockit.man\n"
+ "q3w\n"
+ "e4.45r.d.2\n"
+ "sp_am\n"
+ ".ret.\n"
+ "123\n"
+ "12a\n"
+ "ret..wer\n"
+ "super_.duper\n"
+ "_petrat or petrat_\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}