const regex = /^(?=.*[A-Za-z].*[A-Za-z])([A-Za-z0-9]((?!.*[\._]{2})([\w\d\.]{1,23}))[A-Za-z0-9])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*[A-Za-z].*[A-Za-z])([A-Za-z0-9]((?!.*[\\._]{2})([\\w\\d\\.]{1,23}))[A-Za-z0-9])$', 'gm')
const str = `A.s
0as
a.a
a.0
0.0
a._a
a.0a
1rockit.man
q3w
e4.45r.d.2
sp_am
.ret.
123
12a
ret..wer
super_.duper
_petrat or petrat_
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}