import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:.*[a-z]){2})(?:(?!^[\\W_]|[\\W_]{2}|[\\W_]$)[\\w.]){3,25}$";
final String string = "A.s\n"
+ "0as\n"
+ "a.a\n"
+ "a.0\n"
+ "0.0\n"
+ "a._a\n"
+ "a.0a\n"
+ "1rockit.man\n"
+ "q3w\n"
+ "e4.45r.d.2\n"
+ "sp_am\n"
+ ".ret.\n"
+ "123\n"
+ "12a\n"
+ "ret..wer\n"
+ "super_.duper\n"
+ "_petrat\n"
+ "petrat_\n"
+ "aa\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}