use strict;
my $str = 'A.s
0as
a.a
a.0
0.0
a._a
a.0a
1rockit.man
q3w
e4.45r.d.2
sp_am
.ret.
123
12a
ret..wer
super_.duper
_petrat
petrat_
aa
';
my $regex = qr/^(?=(?:.*[a-z]){2})(?:(?!^[\W_]|[\W_]{2}|[\W_]$)[\w.]){3,25}$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}