#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([\w\s-\(\)]+)</"
Local $sString = "<a class="producto" href="ver.asp?id=4013">A86028</a></span><!-- /a --></td></tr>" & @CRLF & _
" <a class="producto" href="ver.asp?id=4014">1027C</a></span><!-- /a --></td></tr>" & @CRLF & _
" <a class="producto" href="ver.asp?id=4014">5611 4020</a></span>" & @CRLF & _
"<!-- /a --></td></tr>" & @CRLF & _
" <a class="producto" href="ver.asp?id=4014">396-4185</a></span>" & @CRLF & _
"<!-- /a --></td></tr>" & @CRLF & _
" <a class="producto" href="ver.asp?id=4014">834006-5-7</a></span>" & @CRLF & _
"<!-- /a --></td></tr>" & @CRLF & _
" <a class="producto" href="ver.asp?id=4014">5601GR 4325GR</a></span>" & @CRLF & _
"<!-- /a --></td></tr>" & @CRLF & _
" <a class="producto" href="ver.asp?id=4014">2182CR(2)</a></span>" & @CRLF & _
"<!-- /a --></td></tr>" & @CRLF & _
" <a class="producto" href="ver.asp?id=4014">1458-54-63-55</a></span>" & @CRLF & _
"<!-- /a --></td></tr>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")