import Foundation
let pattern = #"([\w\s-\(\)]+)</"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<a class="producto" href="ver.asp?id=4013">A86028</a></span><!-- /a --></td></tr>
<a class="producto" href="ver.asp?id=4014">1027C</a></span><!-- /a --></td></tr>
<a class="producto" href="ver.asp?id=4014">5611 4020</a></span>
<!-- /a --></td></tr>
<a class="producto" href="ver.asp?id=4014">396-4185</a></span>
<!-- /a --></td></tr>
<a class="producto" href="ver.asp?id=4014">834006-5-7</a></span>
<!-- /a --></td></tr>
<a class="producto" href="ver.asp?id=4014">5601GR 4325GR</a></span>
<!-- /a --></td></tr>
<a class="producto" href="ver.asp?id=4014">2182CR(2)</a></span>
<!-- /a --></td></tr>
<a class="producto" href="ver.asp?id=4014">1458-54-63-55</a></span>
<!-- /a --></td></tr>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)