$re = '/^(?!.*banana.*)(?:(?!sandwich).)*ice-cream.*?sandwich.*$/m';
$str = '/ice-cream/stuff/sandwich/banana
/ice-cream/stuff/sandwich/
sandwich//ice-cream/stuff/sandwich
sandwich//ice-cream/stuff/sandwich
sandwich//ice-cream/stuff/sandwich';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);