#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?(DEFINE)" & @CRLF & _
" (?<lc>(?=[^a-z\n]*[a-z])) # lowercase" & @CRLF & _
" (?<uc>(?=[^A-Z\n]*[A-Z])) # uppercase" & @CRLF & _
" (?<digit>(?=[^\d\n]*\d)) # digit" & @CRLF & _
" (?<special>(?=.*[!@]+)) # special character" & @CRLF & _
")" & @CRLF & _
"^(?&lc)(?&uc)(?&digit)(?&special).{6,}$"
Local $sString = "ABC123!s" & @CRLF & _
"testman" & @CRLF & _
"weakpassword" & @CRLF & _
"Lmnttmotm1406!" & @CRLF & _
"Ab1!!!!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")