const regex = /zepit ([\s\S]*?)(?: on (\w+))?$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('zepit ([\\s\\S]*?)(?: on (\\w+))?$', 'i')
const str = `zepit {;d
nknknlkklnf} on stage`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}