package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*(class)\s*test1(\s|(\s*:|:))`)
var str = `class test1
{
}
public class test1
{
}
public class test1
{
}
public class test1
{
}
public class test1:sdfsdf
{
}
public class test1 :sdfsdf
{
}
public class test1 :sdfsdf{}
public class test1 :sdfsddf{}
public class test11 :sdfsdf{}
public class test11 :sdfsdf
{
}
public class test11
{
}
public class test11 :sdfsdfsdf {}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}