import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "h+i+k+e+";
final String string = "I am looking for simple way to have catch variant of word like\n\n"
+ "hike hhike hiike hikke hikkee\n\n"
+ "Using something similar to the format below...\n\n"
+ "[([a-zA-Z]){4,}]\n\n"
+ "Thanks";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}