package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^Help\s*#\s*(\d{3,5})\b`)
var str = `Help # 7256
Help # 83930
ph # 7222
this is a test example
Help # 029299
New # 92929`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}