#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(G{2,5})([ACGT]{1,7})\1([ACGT]{1,7})\1([ACGT]{1,7})\1"
Local $sString = "GGAAAGGAAGGAAGG" & @CRLF & _
"" & @CRLF & _
"GGAAAGGAAGGGAAGG" & @CRLF & _
"^ OK because [ACGT]" & @CRLF & _
"" & @CRLF & _
"GGAAAGGAAGAAGG"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")