using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(G{2,5})([ACGT]{1,7})\1([ACGT]{1,7})\1([ACGT]{1,7})\1";
string input = @"GGAAAGGAAGGAAGG
GGAAAGGAAGGGAAGG
^ OK because [ACGT]
GGAAAGGAAGAAGG";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}