re = /(G{2,5})([ACGT]{1,7})\1([ACGT]{1,7})\1([ACGT]{1,7})\1/
str = 'GGAAAGGAAGGAAGG
GGAAAGGAAGGGAAGG
^ OK because [ACGT]
GGAAAGGAAGAAGG'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end