re = /(?<!\S)(?!FILE:)\S+/m
str = 'FILE:abc LENGTH:123 AUTHOR:Bobby
FILE:xyz LENGTH:987 AUTHOR:Sabine
FILE:xyz LENGTH:987 AUTHOR:Sabine:test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end