import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^interface (\\S+)\\n?(?:(?: description (.*)| ip address (\\S+) (\\S+)| .*)\\n?)*";
final String string = "interface Null0\n"
+ " no ip unreachables\n"
+ "interface Loopback0\n"
+ " ip address 1.1.1.1 255.255.255.255\n"
+ " no ip redirects\n"
+ " no ip proxy-arp\n"
+ "interface GigabitEthernet0/0/0\n"
+ " description BTCM Hello World \n"
+ " bandwidth 22000\n"
+ " ip address 2.2.2.2 255.255.255.252\n"
+ " no ip redirects\n"
+ " no ip unreachables\n"
+ " no ip proxy-arp\n"
+ "interface GigabitEthernet0/0/1\n"
+ " description Interface going to router X\n"
+ " bandwidth 1000000\n"
+ " ip address 3.3.3.3 255.255.255.252\n"
+ " no ip redirects\n"
+ " no ip unreachables";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}