# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^interface (\S+)\n?(?:(?: description (.*)| ip address (\S+) (\S+)| .*)\n?)*"
test_str = ("interface Null0\n"
" no ip unreachables\n"
"interface Loopback0\n"
" ip address 1.1.1.1 255.255.255.255\n"
" no ip redirects\n"
" no ip proxy-arp\n"
"interface GigabitEthernet0/0/0\n"
" description BTCM Hello World \n"
" bandwidth 22000\n"
" ip address 2.2.2.2 255.255.255.252\n"
" no ip redirects\n"
" no ip unreachables\n"
" no ip proxy-arp\n"
"interface GigabitEthernet0/0/1\n"
" description Interface going to router X\n"
" bandwidth 1000000\n"
" ip address 3.3.3.3 255.255.255.252\n"
" no ip redirects\n"
" no ip unreachables")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.