$re = '/\[(text)\s*=\s*"([^"]+)"\](.*?)\[\/\1\]/mi';
$str = '[text="This is the title"]This is the content of the title[/text]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);