re = /\[(text)\s*=\s*"([^"]+)"\](.*?)\[\/\1\]/mi
str = '[text="This is the title"]This is the content of the title[/text]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end