$re = '/(?\'type\'.*?) (?\'name\'.*)/';
$str = 'QString CurrentVideoSource';
$subst = "Q_PROPERTY(\{type} \{name} READ \{name} WRITE set\{name} NOTIFY \{name}Changed)\n\n\{type} \{name}() const\n{ return m_\{name}; }\n\nvoid set\{name}(\{type} \{name})\n{\n\tif(this->m_\{name} != \{name})\n\t{\n\t\tthis->m_\{name} = \{name};\n\t\temit \{name}Changed();\n\t}\n}\n\nvoid \{name}Changed();\n\n\{type} m_\{name};";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;