using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((http(s)?):\/\/)?(www.)?([\da-zA-z\_\-]+)\.(com|(|[\da-zA-Z]{2,6}))([\/\w \.\-\#\&\?\%\_]*)?([^\/| |\s])$";
string input = @"https://www.test.com/
https://www.test.com/
https://test.com/
https://test.com
https://www.test.com/
https://www.test.com/directory/
https://www.test.com/directory/
https://www.test.com/directory/directory/
https://www.test.com/directory/directory/
www.test.net/
http://www.test.net/
https://www.test.net/
https://www.test.net/directory/
https://www.test.net/directory/directory/directory
test.org/
www.test.net
www.test.gov
www.test.gov/
test.gov/
www.test.org
www.test.com/
http://www.test.com/
https://www.test.com/directory/news-events/index.html?date=2013-05-01
https://test.test.com/directory/news-events/index.html?date=2013-07-07";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}