# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((http(s)?):\/\/)?(www.)?([\da-zA-z\_\-]+)\.(com|(|[\da-zA-Z]{2,6}))([\/\w \.\-\#\&\?\%\_]*)?([^\/| |\s])$"
test_str = ("https://www.test.com/ \n"
"https://www.test.com/\n"
"https://test.com/ \n"
"https://test.com\n"
"https://www.test.com/ \n"
"https://www.test.com/directory/\n"
"https://www.test.com/directory/ \n"
"https://www.test.com/directory/directory/\n"
"https://www.test.com/directory/directory/ \n"
"www.test.net/\n"
"http://www.test.net/ \n"
"https://www.test.net/ \n"
"https://www.test.net/directory/\n"
"https://www.test.net/directory/directory/directory\n"
"test.org/ \n"
"www.test.net\n"
"www.test.gov\n"
"www.test.gov/\n"
"test.gov/\n"
"www.test.org\n"
"www.test.com/ \n"
"http://www.test.com/\n"
"https://www.test.com/directory/news-events/index.html?date=2013-05-01\n"
"https://test.test.com/directory/news-events/index.html?date=2013-07-07")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.