#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<SharedDataSetReference>([^\/]+)<\/SharedDataSetReference>"
Local $sString = "<SharedDataSetReference>Company</SharedDataSetReference>" & @CRLF & _
"<SharedDataSetReference>Customer</SharedDataSetReference>" & @CRLF & _
"<SharedDataSetReference>/DataSets/AnyDataSetName</SharedDataSetReference>" & @CRLF & _
"<SharedDataSetReference>AnyDataSetName</SharedDataSetReference>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")