Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(?!.*window\.).*\b(console\.log|alert\().*$
/
gm
Input 1
1
New
console.log("dddsdsf"); alert("dasassd"); window.alert("asdasasasd");