#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(^[a-z]{1}\d{4}[a-z]{3}$|^\d{4}$)"
Local $sString = "1001" & @CRLF & _
"1106" & @CRLF & _
"x1001abc" & @CRLF & _
"1111" & @CRLF & _
"AAAA" & @CRLF & _
"a111111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")