const regex = new RegExp('(^[a-z]{1}\\d{4}[a-z]{3}$|^\\d{4}$)', 'gmi')
const str = `1001
1106
x1001abc
1111
AAAA
a111111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}