import re
regex = re.compile(r"(^[a-z]{1}\d{4}[a-z]{3}$|^\d{4}$)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("1001\n"
"1106\n"
"x1001abc\n"
"1111\n"
"AAAA\n"
"a111111")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")