#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[ ]{4,}|\t{1,})(.+)"
Local $sString = "This is a code block:" & @CRLF & _
"" & @CRLF & _
" I need capturing along with" & @CRLF & _
" this line" & @CRLF & _
"" & @CRLF & _
"This is a code fence below (to be ignored):" & @CRLF & _
"" & @CRLF & _
"``` json" & @CRLF & _
"This must have three backticks" & @CRLF & _
"flanking it" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"I love `inline code` too but don't capture" & @CRLF & _
"" & @CRLF & _
"and one more short code block:" & @CRLF & _
"" & @CRLF & _
" Capture me" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")