const regex = /(?:[ ]{4,}|\t{1,})(.+)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[ ]{4,}|\\t{1,})(.+)', 'mg')
const str = `This is a code block:
I need capturing along with
this line
This is a code fence below (to be ignored):
\`\`\` json
This must have three backticks
flanking it
\`\`\`
I love \`inline code\` too but don't capture
and one more short code block:
Capture me
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}