# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)(?<=^[^:]+):/=/gm;t' <<< "id : AA:BB:CC:DD:11:22
connectionStatus : CONNECTED
hostType : WIRELESS
authType : WPA2/WPA3+802.1x/FT-802.1x"