import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*(201710)[0-9]{2}.*$";
final String string = "ing_smac_process_data_full_20171025_csv\n"
+ "ing_smaci_process_data_delta_20171026_csv\n"
+ "ing_smaci_process_data_delta_20171027_csv\n"
+ "ing_smaci_process_data_delta_20171028_csv\n"
+ "ing_smaci_process_data_delta_20171029_csv\n"
+ "ing_smaci_process_data_delta_20171030_csv\n"
+ "ing_smaci_process_data_delta_20171031_csv\n"
+ "ing_smaci_process_data_delta_20171101_csv\n"
+ "ing_smaci_process_data_delta_20171102_csv";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}