re = /^.*(201710)[0-9]{2}.*$/m
str = 'ing_smac_process_data_full_20171025_csv
ing_smaci_process_data_delta_20171026_csv
ing_smaci_process_data_delta_20171027_csv
ing_smaci_process_data_delta_20171028_csv
ing_smaci_process_data_delta_20171029_csv
ing_smaci_process_data_delta_20171030_csv
ing_smaci_process_data_delta_20171031_csv
ing_smaci_process_data_delta_20171101_csv
ing_smaci_process_data_delta_20171102_csv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end